Problemas instalando el mysql gem en Ubuntu

La situacion es que actualizaste tu Ruby on Rails, o instalaste la nueva versión y te diste cuenta de que necesita el gem de mysql instalado para funcionar. Entonces abriste tu constola y escribiste:
$ sudo gem install mysql.
Pero entonces obtuviste un bonito error:

ERROR: While executing gem … (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/mysql-2.7 for inspection.

El problema está en que el gem de mysql necesita el paquete de desarrollo de mysql para compilar y asi poder instalarse, asi que sólo debes instalarlo primero:
$ sudo apt-get install libmysqlclient15-dev
Ya que lo tienes vuelve a intentar obtener el gem:
$ sudo gem install mysql.
Y listo ya quedo. Ahora puede pasar que el gem no pueda instalarse aun después de esto debido a que no hay espacio suficiente en la carpeta /tmp para escibir, si te pasa esto, reinicia para que se libere el
espacio que necesitas sin eliminar nada que puedas necesitar, vuelves a intentar y ya.

Ahí lo tienen.
Recommend Me

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: